Looks like your connection to Bethesda.net Community Beta was lost, please wait while we try to reconnect.

Quake Champions - Can't Map Keys at all.



I started up the game for the first time, and there were no keybindings. I couldn't even walk around the training mission or move or anything. escape keys work. i can type letters in chat. -But i otherwise can not do anything game related short of navigating the menus.

I went into settings > controls > movement
and i can't do anything. i click on the field for move forward(or any key), and the dialogue pops up indicating press a key, but no matter which key i press, or which keyboard i use, it will not accept my key, and sits there. I can't even press esc, so i have to reboot the game. 

i've tried a logictech keyboard, and a dell keyboard. both are USB types. Neither are using 3RD party software or drivers. just straight stock drivers.
this keyboard mouse combination has worked for every single game since the beginning of time.

computer is a typical setup.
amd processor 3.6ghz/16GB RAM/EVGA-Nvidia dual GPU Card(SLI Mode)
GigaByte GA-MA790XT-UD4P
windows7/full updates.
yu-0003-dell5 keyboard
RX 250 Logitech Mouse
-also tried a Logitech k400r keyboard w/mousepad

everything runs pretty smooth, but the keybindings will not work.
config works for all games. never seen this kind of problem before.
runs doom2016 perfectly.

I checked \users\\AppData\Local\id Software\Quake Champions\client\config
and at first there no files in there except the config and video cfgs.
Now I got Config, Game, Video, and Input cfgs, but most appear empty with only a few settings, 
and absolutely no mention of key bindings in any of them.

One guy suggested deleting everything in there, and restarting the game, but that didn't help.

dxdiag reports no errors.
all keyboards are USB/HID keyboards w/HID windows service running.

running Quake Champions Free from the Steam App available for download now.

any ideas wth is going on here, or have a sample keyboard binding file I can import/copy over to 
see if that works??

I'm out of ideas. The game simply will not work with any keyboards or mice I have sitting around
which leads me to believe it's not a hardware issue, but rather a game issue.

you can follow the steam version of the thread here.  -  https://steamcommunity.com/app...



@mtrx2010 

Your issue with keybindings not working could be a permission issue. The first thing you can try is running both Quake and the launcher as an administrator and see if the keys work again. If not, you should check what programs are running in the background and disable any that have a third party overlay. Please let us know if either of these make a difference.



As above, plus if testing running as administrator doesn't help, in case there are issues with extended characters if you have any non Latin/English characters in your windows username/account name if you could test creating a new windows account with a simple name and run steam from that to test the game.

If that proves to be the problem, or you are still having problems, please contact support via https://help.bethesda.net and and let them know your system details, including windows language settings.